Описание процесса первичной интеграции учетной базы клиента на базе 1С в режиме прямой интеграции.

Требования

  1. Наличие шаблонной конфигурации. Для загрузки шаблона перейти по ссылке http://pub.aspcom.ru/%D0%BA%D0%BE%D0%BC%D0%BF%D0%BE%D0%BD%D0%B5%D0%BD%D1%82%D1%8B:%D1%88%D0%B0%D0%B1%D0%BB%D0%BE%D0%BD
  2. Наличие персональной внешней обработки.

Порядок действий

  1. Открыть конфигуратор, нажать на меню «Конфигурация».
  2. Выбрать пункт «Сравнить, объединить с конфигурацией из файла».

  1. Выбрать файл шаблона (загруженный ранее), кликнув на него.
  2. Нажать кнопку «Открыть».

В столбце убрать галочку в начале списка ⇒ При снятии галочки должны сняться со всех объектов.

Нажать кнопку «Действия».
Выбрать пункт «Отметить по подсистемам файла».

  1. В окне «Отбор по подсистемам» снять галочку в основном «АСП_Меркурий».
  2. Ниже если необходимо настроить не управляемую форму программы, выделить галочкой «АСП_Меркурий», если управляемую форму — то выделить «АСП_МеркурийУФ».
  3. Нажать кнопку «Установить».

  1. Нажать кнопку «Выполнить».
  2. Нажать кнопку «Сохранить» ⇒ Появится сообщение «Использовать в справочниках организации, контрагентов и номенклатур из шаблона».

Подготовка

Если есть копия базы с УРБД на которую необходимо перенести изменения, предварительно необходимо удалить связь УРБД.

Объединение конфигураций

Объединить конфигурацию учётной базы с шаблонной и выбрать объекты по подсистеме из файла АСП_Меркурий или АСП_МеркурийУФ (для управляемых форм)

Роли пользователей

  1. Назначить администратору роль АСП_Администратор.
  2. Назначить уполномоченному лицу роль АСП_ВетВрач, а также набор ролей доступности интерфейса.
  3. Назначить роль АСП_Пользователь всем пользователям, имеющим доступ к изменению справочников учётной системы.

Подписка на события

Проверить подписку событий АСП_ЗаписьСправочников. Необходимо указать ссылки на все справочники, являющиеся хозяйствующими или поднадзорными объектами в рамках подсистемы. Например:

  • Контрагенты
  • Организации
  • Номенклатура

Необходимо отметить все справочники, которые будут использоваться для интеграции. Они так же указываются в АСП роли справочников.

Кнопки «Меркурий» (обычные формы)

Для доступа к реквизитам подсистемы АСП_Меркурий необходимо добавить кнопки на карточки справочников. Примеры добавляемых кнопок есть в шаблоне.

Например, для добавления кнопки на карточку товара, добавить в модуль формы номенклатуры, в процедуру При открытии:

ЭлементыФормы.ДействияФормы.Кнопки.Добавить("Меркурий", ТипКнопкиКоманднойПанели.Действие, "Меркурий", Новый Действие("ДействияФормыАСП_Меркурий"));

Также добавить для события процедуру:

Процедура ДействияФормыАСП_Меркурий(Кнопка)
    АСП_Функции.ПолучитьЗапись(Ссылка, 2).ПолучитьФорму().Открыть();
КонецПроцедуры

Примеры для карточек Организаций / Контрагентов:

ЭлементыФормы.ДействияФормы.Кнопки.Добавить("Меркурий", ТипКнопкиКоманднойПанели.Действие, "Меркурий хоз", Новый Действие("ДействияФормыАСП_Меркурий"));
ЭлементыФормы.ДействияФормы.Кнопки.Добавить("Меркурий2", ТипКнопкиКоманднойПанели.Действие, "Меркурий под", Новый Действие("ДействияФормыАСП_Меркурий2"));
Процедура ДействияФормыАСП_Меркурий(Кнопка)
    АСП_Функции.ПолучитьЗапись(Ссылка, 0).ПолучитьФорму().Открыть();
КонецПроцедуры
Процедура ДействияФормыАСП_Меркурий2(Кнопка)
    АСП_Функции.ПолучитьЗапись(Ссылка, 1).ПолучитьФорму().Открыть();
КонецПроцедуры

Кнопки Меркурий (управляемые формы)

Указать для общих команд «Тип параметра команды»:

  • АСП_Хозяйствующие (Организации, Контрагенты)
  • АСП_Поднадзорные (Организации, Контрагенты)
  • АСП_Товары (Номенклатура)

Настройка модулей

  1. В меню нажать маркировку на пункте «Общие модули».
  2. Выбрать пункт «АСП_Общее», кликнув на него. Данный модуль использует и хранит логику клиентов. Остальные модули типовые, которые переодически могут обновляться.

  1. В правой части окна конфигуратора найти модуль «АСП_ЗаписьСправочниковПриЗаписи». Он отвечает за заполнение справочников хозяйствующих и поднадзорных.
  2. Подправить как Вам требуется.

  1. В меню выбрать пункт «Регистры сведений».
  2. Выбрать пункт «ОбщееЗапрос Товаров», кликнув на него. В данном модуле отражается логика заполнения ветеринарных сертификатов, где количество — это вес, а количество упаковок — это количество упаковок.
  3. Подправить как Вам требуется.

— Выбрать пункт «ДозаполнитьПоляВетСертификата 1С», кликнув на него. Модуль позволяет при создании сертификатов заполнить его необходимыми полями, например датами выработки, сроками годности или дополнительными фильтрами.

Каждый из видов сертификатов оформляется по особенному.

  • ОбъектСертификата.ВидДокумента.ТипСертификата = Перечисления.АСП_ТипВетСертификата.Входящий
  • ОбъектСертификата.ВидДокумента.ТипСертификата = Перечисления.АСП_ТипВетСертификата.Исходящий
  • ОбъектСертификата.ВидДокумента.ТипСертификата = Перечисления.АСП_ТипВетСертификата.Входящий

Начальные настройки

Заполнить справочник АСП_ВидыДокументов1С

Заполнить справочник АСП_РолиСправочников

Открыть внешнюю обработку и указать основных инициаторов:

  1. Основная организация
  2. Основной вет. врач

Общий модуль

Подготовить общий модуль.

Загрузка справочников

Открыть сервисное меню обработки и нажать кнопки:

  1. Обновить общие справочники
  2. Обновить регионы Меркурий
  3. Перезаписать справочники
  4. Обновить известные хоз.

Сопоставление организаций

Сопоставить основные организации и места доставки в обработке на вкладке Справочники → Организации:

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *